Beim Berechnen einer Summe sollen nicht alle Elemente des ausgewählten Bereichs berücksichtigt werden. Die Auswahl kann von Eigenschaften der Werte oder von Werten anderer Zellen abhängen, die Bedingungen sind zum Teil variabel.

Excel bietet verschiedene Möglichkeiten und Funktionen zur bedingten Summenbildung. Die richtige Auswahl hängt von der Art der Bedingungen ab. Wenn für jeden in Betracht kommenden Wert eine feste Bedingung gilt, verwenden Sie die Funktion “SUMMEWENN”. Falls mehrere Bedingungen zu berücksichtigen sind, gibt es ab Excel 2007 zusätzlich die Funktion “SUMMEWENNS”. Bei variablen Bedingungen benötigen Sie dagegen eine Matrixformel oder die Funktion “SUMMENPRODUKT”. Folgendes Beispiel verdeutlicht die Unterschiede. Angenommen, in den Zellen “A1″ bis “A10″ stehen die Daten und in den Zellen “B1″ bis “C10″ diverse Werte, die für Bedingungen verwendet werden.
FESTE BEDINGUNG: Nun sollen alle Werte der Spalte “A” summiert werden, für die der jeweilige Wert der Spalte “B” größer als “10″ ist. Dafür verwenden Sie die Formel

=SUMMEWENN(B1:B10;”>10″;A1:A10)

Das erste Argument “B1:B10″ definiert den auszuwertenden Bereich, danach folgt die Bedingung “”>10″”. Beachten Sie dabei, dass Bedingungen mit Symbolen oder Operatoren in Anführungszeichen stehen müssen. Schließlich definiert “A1:A10″ den zu summierenden Bereich. Die Bereiche für Bedingungen und Daten können auch identisch sein, sodass dann die Formel

=SUMMEWENN(A1:A10;”>10″
)

ausreicht. Ab Excel 2007 weitet die Funktion “SUMMEWENNS” dieses Prinzip auf maximal 127 Bedingungen aus. Beachten Sie dabei aber die andere Reihenfolge der Argumente. Hier steht zuerst der zu summierende Bereich. Danach folgen jeweils ein Kriterienbereich sowie die zugehörige Bedingung, wobei die Bereiche stets getrennt anzugeben sind. Zum Beispiel summiert die Formel

=SUMMEWENNS(A1:A10;B1:B10;”>10″; C1:C10;”<100″)

alle Werte der Spalte “A”, für die die korrespondierenden Werte der Spalte “B” größer als “10″ und die entsprechenden Werte der Spalte “C” kleiner als “100″ sind. VARIABLE KRITERIEN: Sind die Bedingungen für die Summenbildung komplexer, etwa: “wenn der Wert in Spalte B größer als derjenige in Spalte C”, ist zum Auswerten eine Matrixformel erforderlich. Die Auswahl der zu berücksichtigenden Werte erfolgt durch Multiplikation mit einem Logikwert. Dazu geben Sie zum Beispiel

=SUMME(A1:A10*(B1:B10>C1:C10))

ein und schließen die Eingabe unbedingt mit der Tastenkombination [Strg]+ [Umsch] +[Eingabe] ab – Excel stellt die Formel dann in geschweiften Klammern dar. Das gleiche Ergebnis erzielen Sie in diesem Fall auch mit der Funktion

=SUMMENPRODUKT(A1:A10;1* (B1:B10>C1:C10))

Wichtig dabei ist das Multiplizieren des zweiten Arguments mit “1″, um den Logikwert in eine Zahl umzuwandeln.
Hinweis: In praktisch allen Fällen können Sie die Summenbildung übersichtlich mit einer Hilfsspalte realisieren. Dies empfiehlt sich besonders während der Entwicklung einer Kalkulation, um die Ergebnisse der komplexen Formeln zu überprüfen.

Ähnliche Beiträge:

Gilt für: Excel 2003, 2007, 2010